Performance Degradation Affecting a Subset of Cloud Instances

Incident Report for TestRail Cloud

Resolved

The issue affecting a small subset of customers has been resolved and all services are now fully operational. Thank you for your patience.
Posted Aug 14, 2026 - 15:39 UTC

Monitoring

We continue to closely monitor performance for the affected Cloud instances following the mitigation applied earlier. Our team has identified a permanent resolution, which is currently undergoing review and testing. Thank you for your continued patience while we finalize this work.
Posted Aug 12, 2026 - 16:15 UTC

Identified

We identified a performance issue affecting a subset of TestRail Cloud accounts, resulting in slower page load times for some users. Our team identified the underlying cause and implemented a mitigation that has stabilized performance.

We are continuing to closely monitor the environment while we work toward a permanent resolution. We appreciate your patience and understanding as we work to fully resolve the issue.
Posted Aug 11, 2026 - 18:03 UTC
This incident affected: TestRail Cloud.